• Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

Search results

  1. A

    Hydraulic / Electric problem. Fermec 965 2000 mod.

    Hi, yes I have it and it seems to be working quite well now. So far no problems.
  2. A

    Hydraulic / Electric problem. Fermec 965 2000 mod.

    Hi, yeah I have done that several times. I eventually sent the joysticks in to a company that rebuilds electrical components and they said that the sliding surfaces of the joystick's potentiometers are way too worn out. Potentiometer joysticks have a limited lifetime. So they could not do...
  3. A

    Fermec 965 (Terex)

    Hi, how would you go about bypassing that sensor? is it just a straight contact sensor? could you do the same with the wheel position sensors?
  4. A

    Hydraulic / Electric problem. Fermec 965 2000 mod.

    Have you had any luck with your machine?
  5. A

    Fermec 965 1999

    Hi, Thanks for that and sorry for the late response. I figured out that I had accidentally switched on the forward switch by the joystick so it was engaged and not starting. So that solved that issue however I have the electrical controls on mine and the hydraulic issue is still going on. It is...
  6. A

    Fermec 965 1999

    Hi all, I have a fermec 965, the other night I was plouging snow and hydraulics stoped working. Its due to the wheel position sensors. Any way I was moving it back and forth to get it to work again and then it suddenly stayed in reverse. I can shift it to forward, neutral, reverse and it just...
  7. A

    Fermec 965 (Terex)

    Hello, have any of you been able to sort this problem? My hydraulics are very shaky. Sometimes they dont work at all. It seems to happen mostly when the machine warms up, about 30 min - 1hr of running then it starts and gets really bad. In the video you can see how it is...
  8. A

    Problem with hydraulikk/ electronikk on my Fermac 965/2000mod.

    Hello, have any of you been able to sort this problem? My hydraulics are very shaky. Sometimes they dont work at all. It seems to happen mostly when the machine warms up, about 30 min - 1hr of running then it starts and gets really bad. In the video you can see how it is...
  9. A

    Hydraulic / Electric problem. Fermec 965 2000 mod.

    Hello, have any of you been able to sort this problem? My hydraulics are very shaky. Sometimes they dont work at all. It seems to happen mostly when the machine warms up, about 30 min - 1hr of running then it starts and gets really bad. In the video you can see how it is...
Top