• Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

Bobcat 773G RH thumb toggle not engaging

Pineyman

New Member
Joined
Jun 10, 2020
Messages
3
Location
South Jersey
So I have a 2002 773G which run and drives great. Unfortunately the auxiliary hydraulics seems to only work when I pull the trigger on the RH stick. When I try and toggle the thumb switch on the RH stick nothing happens at all, no engine groan or RPM change when i push it in either direction. I am not getting any codes showing up. I also traced the wires and nothing seems to be corroded or broken. I have plenty of hydraulic oil on board and all other hydraulic functions work great. Any ideas on how I might resolve this?
 

Pineyman

New Member
Joined
Jun 10, 2020
Messages
3
Location
South Jersey
Update, I found a blown 25A fuse and replaced, but it still will not function. I also took off one of the spool solenoid valves and tried to get it to magnetize but it did not seem to be getting any power to it.
 

Greg Burtoni

New Member
Joined
Sep 14, 2021
Messages
4
Location
Wisconsin
Did you ever figure out the problem? I recently purchased a 2002 773 and i am experiencing the exact same issue you were having.
 

tschla56

New Member
Joined
Jun 15, 2024
Messages
2
Location
Texas
I have the same problem with the right toggle not working
Update, I found a blown 25A fuse and replaced, but it still will not function. I also took off one of the spool solenoid valves and tried to get it to magnetize but it did not seem to be getting any power to it.
Did you get this fixed. I am experiencing the same problem.
 

tschla56

New Member
Joined
Jun 15, 2024
Messages
2
Location
Texas
Update, I found a blown 25A fuse and replaced, but it still will not function. I also took off one of the spool solenoid valves and tried to get it to magnetize but it did not seem to be getting any power to

Did you ever figure out the problem? I recently purchased a 2002 773 and i am experiencing the exact same issue you were having.
Do anybody have an answer to why this right toggle is not working?
 

KOBE STEEL

Well-Known Member
Joined
May 21, 2024
Messages
146
Location
.
Do anybody have an answer to why this right toggle is not working?
Hello Sir,
If possible could you provide some more details so that myself or someone else can try and be of help. Could you start with the machine serial number and a detailed description of the problem such as when the fault started to occur, any other functions affected, any fault codes displayed and what functions do appear to be working correctly. Give as much details in your reply as you possibly can and we will try and help you resolve the issue.
Best regards
 
Top