• Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

D8t transmission filter screen

Franklin7

Well-Known Member
Joined
Jun 14, 2023
Messages
46
Location
Naches wa
Found this part in the screen filter for the transmission on a d8t. Wondering what it could be or came from. Sometimes when tracking when cold the tracks will lock up. Any thoughts?
 

Attachments

  • 20231113_114744.jpg
    20231113_114744.jpg
    1.3 MB · Views: 54

ahart

Senior Member
Joined
Nov 7, 2020
Messages
889
Location
Indiana
First off, what is the serial number of the machine? Secondly, which screen did you find that inside? The magnetic screen at the pump or the sump screen at the back of the transmission?
 

Franklin7

Well-Known Member
Joined
Jun 14, 2023
Messages
46
Location
Naches wa
First thing in the morning the tracks won't engage then will after a couple trys. After that it is fine the rest of the day. Any ideas?
 

Nige

Senior Member
Joined
Jun 22, 2011
Messages
30,326
Location
G..G..G..Granville.........!! Fetch your cloth.
Do you mean it doesn't want to engage gear or that it engages gear but it appears as though the brakes don't want to release.?

Any recent repair work on the power train (converter, transmission, final drives, brakes)..?
 
Last edited:

Franklin7

Well-Known Member
Joined
Jun 14, 2023
Messages
46
Location
Naches wa
Its always when you go to first fire it up and use it. You put it into first gear and it won't engage or move or it will sometimes move a few feet and then lock up and stop. Seems to just do it in first gear. If you put it into second gear seems to move fine. After you fire it up and are using it then it is fine the rest of the day. Even after it sits after being used and warmed up it doesn't do it.
 

Franklin7

Well-Known Member
Joined
Jun 14, 2023
Messages
46
Location
Naches wa
No recent work has been performed just regular service. The perform service on the transmission filters has come up and I have changed those out a couple times within last 1500 hrs. Machine has 13000 hrs on it.
 

Nige

Senior Member
Joined
Jun 22, 2011
Messages
30,326
Location
G..G..G..Granville.........!! Fetch your cloth.
Cat to-4 sae 30
Well that answers that question. No issues there.

It might be about time to put pressure gauges on the transmission when it's cold and see if there is any difference between how the 1st and 2nd speed clutches react when engaged.

Was there anything else in the suction screen apart from the spool in your photo?
Still baffled as to what it is though.......
 

Franklin7

Well-Known Member
Joined
Jun 14, 2023
Messages
46
Location
Naches wa
Yes both forward or reverse. That part I found in the suction screen has me stumped on what happened and where it came from
 

Franklin7

Well-Known Member
Joined
Jun 14, 2023
Messages
46
Location
Naches wa
Maybe just a few tiny pieces of rubber from maybe a hose or something was in there other than that pretty clean.
 

ahart

Senior Member
Joined
Nov 7, 2020
Messages
889
Location
Indiana
I searched throughout the parts and service manual yesterday and couldn’t find anything that looked like it.
 
Top