• Thank you for visiting HeavyEquipmentForums.com! Our objective is to provide industry professionals a place to gather to exchange questions, answers and ideas. We welcome you to register using the "Register" icon at the top of the page. We'd appreciate any help you can offer in spreading the word of our new site. The more members that join, the bigger resource for all to enjoy. Thank you!

John Deere 328E Electrical issues

Dyl55

Active Member
Joined
Mar 8, 2023
Messages
33
Location
38555
This stared with disconnecting the battery while trying to jump start the machine after it died overnight.
After we jump started the machine it was running then as I went to take the jumper cables off, I pulled the negative battery terminal and the machine turned off and sparks flew either as the terminal was lifting away or when it came back down on the terminal(cant exactly remember when). After wards whenever we would try to unlock the Anti-Theft the machine was saying Unlocking Failed. We were able to get it to turn over at some point but got worse when each time we would turn it over it would turn over less and less till all it would do is click and now there is nothing. The alternator we believed to be part of the issue and the starter was looking crusty so we replaced both to rule them out and in the process found a small wire loom that ran behind the cab in the engine bay was worn through to bare wires. none of these solved the issue.
We are looking for parts if needed and assistance with knowledge on repair.
 

mg2361

Senior Member
Joined
Jul 5, 2016
Messages
5,329
Location
Pennsylvania
Occupation
Equipment Mechanic
Complete machine serial number please?

Keyed or keyless start?

As of right now, when you sit in the seat, turn ignition on, try to start, what exactly happens? Any messages in the monitor? Does it still ask to be unlocked? Any clicks?
 

Dyl55

Active Member
Joined
Mar 8, 2023
Messages
33
Location
38555
1T0328EKTDE243618
Keyless

When you sit on the chair the info panel to the left lights up, I don't remember the lights that come on before the issue, but the one bothering me the most is the hydraulic cylinder with a line through it. Does that just mean it is locked, or worse. When I power the system by pressing the start button nothing different, not until I hold it to start, the secondary light turns on to indicate engine running or start and nothing happens not even a click.
 

Dyl55

Active Member
Joined
Mar 8, 2023
Messages
33
Location
38555
I also looked at the trouble codes and took pictures. I'll compile them in a google drive folder and send the link.
 

mg2361

Senior Member
Joined
Jul 5, 2016
Messages
5,329
Location
Pennsylvania
Occupation
Equipment Mechanic
The picture you have is the ECU is not communicating on the network. The ECU may have lost its power supply or ground. Has the F3 ECU 25A fuse been checked? If the fuse is good and voltage is passing through, then check the K20 ECU relay. That would be located under the cab, left side looking in, behind a tin cover. There will be a 2 stacks (one above the other) of relays on the rearward side of that relay block. The K20 should be the top relay of the lower stack.

Post your codes as well. Post the numerical SPN/FMI numbers please (XXXX.XX).
 

Dyl55

Active Member
Joined
Mar 8, 2023
Messages
33
Location
38555
I can remember the number but there is a 25 amp fuse that keeps blowing
 

mg2361

Senior Member
Joined
Jul 5, 2016
Messages
5,329
Location
Pennsylvania
Occupation
Equipment Mechanic
If you are blowing fuses, then the issue needs to be repaired.

And can we get a fuse diagram for the 328E
Fuse diagram or wiring diagram? Wiring diagram will not likely be found online.

Check your messages.

Don't you have an operator's manual? You can view it for free here. Type fuse in the search bar in the upper left and you will find the image below.

Screenshot 2024-01-09 at 4.55.18 AM.png
 

Dyl55

Active Member
Joined
Mar 8, 2023
Messages
33
Location
38555
Yes I did, just stating what I was able to find on the website earlier. Apologies for the confusion.
 

Dyl55

Active Member
Joined
Mar 8, 2023
Messages
33
Location
38555
Could we get a diagram for the fuses and what they are, I looked through the manual you got me and it doesn't say or show anything.
 

Dyl55

Active Member
Joined
Mar 8, 2023
Messages
33
Location
38555
These are currently all the codes the machine is throwing.

EMU 920.05
Alarm output out of range low
VCU 158.03
Battery voltage switched power out of range high
VCU 168.03
Battery voltage unswitched power out of range high
VCU 168.04
Battery voltage unswitched power out of range low
HCU 523217.04
Hydraulic valve power 3 to HCU out of range low
HCU 523219.04
Hydraulic valve power 1 to HCU out of range low
HCU 516193.04
Left foot pedal signal 1 out of range low
EMU 1196.11
Anti-theft unknown fault see manual
HCU 522450.05
Left pump fwd sol current out of range low
EMU 2000.09
No ECU data on CAN bus abnormal data range
ECU 522329.00
Water in fuel switch data above normal
HCU 516195.04
Right foot pedal signal 2 out of range low
HCU 522447.05
Right pump fwd sol current out of range low
EMU 158.01
battery voltage switched power data below normal
ECU 523249.05
Crank and cam sensor out of range low
EMU 522828.07
Creep mode switch input mechanical fault
VCU 3598.03
5 volt sensor supply 2 out of range high
ECU 522323.00
Air filter switch data above normal
ECU 522599.09
CAN Comm Y_ECR1 abnormal data rate
ECU 522597.09
TSC1 CAN message abnormal data rate
 

Dyl55

Active Member
Joined
Mar 8, 2023
Messages
33
Location
38555
The relay is good and the fuse is still burning upon turning accessory power on.
 
Top